Xin chào các bạn, Các bạn có khỏe không? Hy vọng tất cả các bạn vẫn ổn. Hôm nay tôi đang cố gắng chạy cài đặt trình soạn nhạc nhưng tôi gặp phải lỗi sau Root composer.json yêu cầu php ^ 7.3 nhưng phiên bản php (8.0.0) của bạn không đáp ứng yêu cầu đó trong laravel. Vì vậy, ở đây tôi giải thích cho bạn tất cả các giải pháp khả thi ở đây.

Không lãng phí thời gian của bạn, Hãy bắt đầu bài viết này để giải quyết lỗi này.

Cách Root composer.json yêu cầu php ^ 7.3 nhưng phiên bản php (8.0.0) của bạn không thỏa mãn yêu cầu đó Lỗi xảy ra?

Cách giải quyết Root composer.json yêu cầu php ^ 7.3 nhưng phiên bản php (8.0.0) của bạn không đáp ứng yêu cầu đó. Lỗi?

  1. Cách giải quyết Root composer.json yêu cầu php ^ 7.3 nhưng phiên bản php (8.0.0) của bạn không đáp ứng yêu cầu đó. Lỗi?

    Để giải quyết Root composer.json yêu cầu php ^ 7.3 nhưng phiên bản php của bạn (8.0.0) không đáp ứng yêu cầu đó Lỗi này xảy ra do phiên bản php được xác định trong tệp composer.json của bạn mà bạn có một cái gì đó giống như bên dưới. Chỉ cần cập nhật yêu cầu này thành php: ^7.3|^8.0 một cái gì đó như thế này. Giải pháp thứ hai là Nếu bạn đang sử dụng composer install và gặp phải lỗi này thì bạn chỉ cần chạy lệnh composer install với việc bỏ qua các yêu cầu nền tảng ở đây là lệnh Just run this command.

  2. Root composer.json yêu cầu php ^ 7.3 nhưng phiên bản php (8.0.0) của bạn không đáp ứng yêu cầu đó

    Để giải quyết Root composer.json yêu cầu php ^ 7.3 nhưng phiên bản php của bạn (8.0.0) không đáp ứng yêu cầu đó Lỗi này xảy ra do phiên bản php được xác định trong tệp composer.json của bạn mà bạn có một cái gì đó giống như bên dưới. Chỉ cần cập nhật yêu cầu này thành php: ^7.3|^8.0 một cái gì đó như thế này. Giải pháp thứ hai là Nếu bạn đang sử dụng composer install và gặp phải lỗi này thì bạn chỉ cần chạy lệnh composer install với việc bỏ qua các yêu cầu nền tảng ở đây là lệnh Just run this command.

Giải pháp 1: Cập nhật yêu cầu php trong composer.json

Lỗi này xảy ra do phiên bản php được xác định trong tệp composer.json của bạn mà bạn có một cái gì đó giống như bên dưới.

"require": {
    "php": ">=7.3",
},

Chỉ cần cập nhật yêu cầu này thành php: ^7.3|^8.0 một cái gì đó như thế này.

"require": {
    "php": "^7.3|^8.0",
},

Giải pháp 2: Sử dụng lệnh này

Nếu bạn đang sử dụng cài đặt nhà soạn nhạc và bạn đang gặp phải lỗi này thì bạn chỉ cần chạy lệnh cài đặt composer mà bỏ qua các yêu cầu nền tảng đây là lệnh Chỉ cần chạy lệnh này.

composer install --ignore-platform-reqs

Bản tóm tắt

Đó là tất cả về vấn đề này. Hy vọng tất cả các giải pháp đã giúp bạn rất nhiều. Bình luận bên dưới Suy nghĩ của bạn và truy vấn của bạn. Ngoài ra, hãy Comment bên dưới giải pháp nào phù hợp với bạn?