Сегодня столкнулся со следующей ошибкой: Не удалось найти файл в манифесте Vite: resources/css/app.css в Ларавель. В этой статье EZerror мы узнаем, как воспроизвести эту ошибку, и обсудим все возможные решения. Давайте начнем с этой статьи.

Как не удается найти файл в манифесте Vite: возникает ошибка resources/css/app.css?

Я столкнулся со следующей ошибкой

Unable to locate file in Vite manifest: resources/css/app.css

Итак, здесь я пишу все возможные решения, которые я пробовал для устранения этой ошибки.

Как решить Не удается найти файл в манифесте Vite: ошибка resources/css/app.css?

  1. Как решить Не удается найти файл в манифесте Vite: ошибка resources/css/app.css?

    Решить Невозможно найти файл в манифесте Vite: resources/css/app.css Ошибка Вам необходимо установить laravel-vite-плагин сначала, а затем вы можете установить пакет breeze следующим образом: npm install –save-dev vite laravel-vite-plugin && npm install –save-dev @vitejs/plugin-vue Затем вы можете установить ларавель/бриз: композитору требуется laravel/breeze –dev && php artisan breeze:install vue Затем вам нужно выполнить следующую команду: npm install && npm run dev && php artisan migrate и теперь ваша ошибка должна быть решена. Спасибо.

  2. Не удалось найти файл в манифесте Vite: resources/css/app.css

    Чтобы решить Не удалось найти файл в манифесте Vite: resources/css/app.css Ошибка Вам просто нужно выполнить следующую команду в терминале проекта laravel: нпм запустить разработчик И теперь ваша ошибка vite должна быть решена. Спасибо.

Решение 1. Запустите эту команду

Чтобы решить Не удалось найти файл в манифесте Vite: resources/css/app.css Ошибка Вам просто нужно выполнить следующую команду в терминале проекта laravel.

npm run dev

И теперь ваша ошибка vite должна быть решена. Спасибо.

Решение 2. Установите плагин laravel-vite

Вам нужно установить laravel-vite-плагин сначала, а затем вы можете установить пакет breeze точно так же.

Сначала установите плагин laravel-vite, просто используя эту команду.

npm install --save-dev vite laravel-vite-plugin
npm install --save-dev @vitejs/plugin-vue

Затем вы можете установить ларавель/бриз

composer require laravel/breeze --dev
php artisan breeze:install vue

Затем вам нужно выполнить следующую команду.

npm install
  
npm run dev
php artisan migrate

и теперь ваша ошибка должна быть решена. Спасибо.

Вывод

Все дело в этой ошибке. Я надеюсь, что мы решили вашу ошибку. Комментарий ниже Ваши мысли и ваши вопросы. Кроме того, прокомментируйте ниже, какое решение сработало для вас?