Hei folkens, hvordan har dere det? Håper dere alle har det bra. I dag implementerer jeg firebase i appen min, men jeg står overfor følgende feil Forsøk på importfeil: ‘firebase/app’ inneholder ikke en standard eksport (importert som ‘firebase’) i ReactJs. Så her er jeg Forklar deg alle mulige løsninger her.

Uten å kaste bort tiden din, la oss starte denne artikkelen for å løse denne feilen.

Hvordan forsøkt importfeil: ‘firebase/app’ inneholder ikke en standard eksportfeil (importert som ‘firebase’) Feil oppstår?

I dag implementerer jeg firebase i appen min, men jeg står overfor følgende feil.

./src/firebase.js Attempted import error: 'firebase/app' does not contain a default export (imported as 'firebase').

Her er koden min.

import firebase from "firebase/app";
import "firebase/auth";

Slik løser du forsøkt importfeil: ‘firebase/app’ inneholder ikke en standard eksportfeil (importert som ‘firebase’)?

  1. Slik løser du forsøkt importfeil: ‘firebase/app’ inneholder ikke en standard eksportfeil (importert som ‘firebase’)?

    For å løse forsøk på importfeil: ‘firebase/app’ inneholder ikke en standard eksport (importert som ‘firebase’) Feil Hvis du bruker versjon 9, så ikke glem at ting endret seg litt for import av firebase. Nå er det en compatibility så kan bruke /compat-mappen i importene dine. Her er et eksempel Erstatt denne linjen. importere firebase fra firebase/app; Med Denne importerer firebase fra ‘firebase/compat/app’; andre løsning er Hvis du står overfor denne feilen, er det bare å nedgradere til en av firebase-versjonene som er lavere enn v9.

  2. Forsøk på importfeil: ‘firebase/app’ inneholder ikke en standard eksport (importert som ‘firebase’)

    For å løse forsøk på importfeil: ‘firebase/app’ inneholder ikke en standard eksport (importert som ‘firebase’) Feil Hvis du bruker versjon 9, så ikke glem at ting endret seg litt for import av firebase. Nå er det en compatibility så kan bruke /compat-mappen i importene dine. Her er et eksempel Erstatt denne linjen. importere firebase fra firebase/app; Med Denne importerer firebase fra ‘firebase/compat/app’; andre løsning er Hvis du står overfor denne feilen, er det bare å nedgradere til en av firebase-versjonene som er lavere enn v9.

Løsning 1: bruk mappen /compat i import

Hvis du bruker versjon 9, så ikke glem at ting endret seg litt for import av firebase. Nå er det en compatibility så kan bruke /kompat mappen i importene dine. Her er et eksempel.

Bytt ut denne linjen.

import firebase from "firebase/app";

Med dette.

import firebase from 'firebase/compat/app';

Her er et eksempel som er endret i versjon 9

//to use firebase app
import firebase from 'firebase/app'; //older version
import firebase from 'firebase/compat/app'; //v9

//to use auth
import 'firebase/auth'; //older version
import 'firebase/compat/auth'; //v9

//to use firestore
import 'firebase/firestore'; //Older Version
import 'firebase/compat/firestore'; //v9

Løsning 2: Nedgrader firebase-versjonen

Hvis du står overfor denne feilen, er det bare å nedgradere til en av firebase-versjonene som er lavere enn v9.

Løsning 3: lag et Firebase App-objekt som eksempelet nedenfor

  1. Installer Firebase med npm.
  2. npm installer firebase
  3. Initialiser Firebase i appen din og lag et Firebase-appobjekt som dette eksemplet nedenfor.
import { initializeApp } from 'firebase/app';

// TODO: Replace the following with your app's Firebase project
configuration const firebaseConfig = {   //... };

const app = initializeApp(firebaseConfig);

Sommerlig

Alt handler om dette problemet. Håper alle løsninger hjalp deg mye. Kommenter under Dine tanker og spørsmål. Kommenter også under hvilken løsning som fungerte for deg?