Ciao ragazzi, come state? Spero che stiate tutti bene. Oggi, se sto provando a installare una nuova libreria fsevents, sto riscontrando il seguente errore npm WARN notsup SALTARE DIPENDENZA FACOLTATIVA: piattaforma non supportata per [email protected] in javascript. Quindi eccomi qui ti spiego tutte le possibili soluzioni.

Senza perdere tempo, iniziamo questo articolo per risolvere questo errore.

How npm WARN notsup SALTARE LA DIPENDENZA FACOLTATIVA: piattaforma non supportata per [email protected] Si verifica un errore?

se sto provando a installare una nuova libreria fsevents, sto riscontrando il seguente errore.

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_moduleswatchpack-chokidar2node_modulesfsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})    
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] ([email protected]_modulesfsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})    
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modulesfsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})     
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_moduleswebpack-dev-servernode_modulesfsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})    
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_moduleskarmanode_modulesfsevents):

Come risolvere npm WARN notsup SALTARE LA DIPENDENZA FACOLTATIVA: piattaforma non supportata per [email protected] Errore?

  1. Come risolvere npm WARN notsup SALTARE LA DIPENDENZA FACOLTATIVA: piattaforma non supportata per [email protected] Errore?

    Per risolvere npm WARN notsup SALTARE LA DIPENDENZA FACOLTATIVA: piattaforma non supportata per [email protected] Errore Installa semplicemente la libreria di installazione forzata con il seguente comando ma non dovrei preoccuparmi. Potresti anche aggiungerlo a “optionalDependencies”: [] nel tuo .package.json se si desidera eseguire una nuova installazione, questo dovrebbe eliminare gli avvisi, ma è necessario assicurarsi di ottenere la versione corretta.

  2. npm WARN notsup SALTARE DIPENDENZA FACOLTATIVA: piattaforma non supportata per [email protected] Errore

    Per risolvere npm WARN notsup SALTARE LA DIPENDENZA FACOLTATIVA: piattaforma non supportata per [email protected] Errore Installa semplicemente la libreria di installazione forzata con il seguente comando ma non dovrei preoccuparmi. Potresti anche aggiungerlo a “optionalDependencies”: [] nel tuo .package.json se si desidera eseguire una nuova installazione, questo dovrebbe eliminare gli avvisi, ma è necessario assicurarsi di ottenere la versione corretta.

Soluzione 1

Installa semplicemente l’installazione forzata della libreria con il seguente comando ma non dovrei preoccuparmi. Potresti anche aggiungerlo a “optionalDependencies”: [] nel tuo .package.json se si desidera eseguire una nuova installazione, questo dovrebbe eliminare gli avvisi, ma è necessario assicurarsi di ottenere la versione corretta.

npm install -f

Estivo

È tutto su questo problema. Spero che tutte le soluzioni ti abbiano aiutato molto. Commenta qui sotto I tuoi pensieri e le tue domande. Inoltre, commenta di seguito quale soluzione ha funzionato per te?

Leggi anche