Hallo Leute, wie geht es euch allen? Hoffe es geht euch allen gut. Heute verwende ich Visual Studio Code, aber ich stehe vor einer Popup-Meldung Zur Ausführung ist Java 11 oder neuer erforderlich. Bitte laden Sie ein aktuelles JDK herunter und installieren Sie es in Java. Also hier bin ich Erkläre dir hier alle möglichen Lösungen.

Beginnen wir mit diesem Artikel, um diesen Fehler zu beheben, ohne Ihre Zeit zu verschwenden.

Wie Java 11 oder neuer für die Ausführung erforderlich ist. Bitte laden Sie ein aktuelles JDK herunter und installieren Sie es.

Ich verwende Visual Studio Code, aber ich sehe eine Popup-Meldung.

Java 11 or more recent is required to run. Please download and install a recent JDK.

How To Solve Java 11 oder neuer ist zur Ausführung erforderlich. Bitte laden Sie ein aktuelles JDK herunter und installieren Sie es. Fehler ?

  1. How To Solve Java 11 oder neuer ist zur Ausführung erforderlich. Bitte laden Sie ein aktuelles JDK herunter und installieren Sie es. Fehler ?

    To Solve Java 11 oder neuer muss ausgeführt werden. Bitte laden Sie ein aktuelles JDK Error Here to Use herunter und installieren Sie es Spring Boot-Tools Benötigt Java 11, um Spring Boot zu verwenden.

  2. Öffnen Sie Visual Studio-Code
  3. CRTL + , um die Einstellungen zu öffnen
  4. Suche spring-boot.ls.java.home
  5. Wählen Sie „In settings.json bearbeiten“ aus.
  6. Ihre Java 11-Installation → „spring-boot.ls.java.home“: „C:Program FilesJavajdk-11.0.10“
  7. Speichern und starten Sie VS Code neu
  8. Zur Ausführung ist Java 11 oder neuer erforderlich. Bitte laden Sie ein aktuelles JDK herunter und installieren Sie es

    To Solve Java 11 oder neuer muss ausgeführt werden. Bitte laden Sie ein aktuelles JDK Error Here to Use herunter und installieren Sie es Spring Boot-Tools Benötigt Java 11, um Spring Boot zu verwenden.

  9. Öffnen Sie Visual Studio-Code
  10. CRTL + , um die Einstellungen zu öffnen
  11. Suche spring-boot.ls.java.home
  12. Wählen Sie „In settings.json bearbeiten“ aus.
  13. Ihre Java 11-Installation → „spring-boot.ls.java.home“: „C:Program FilesJavajdk-11.0.10“
  14. Speichern und starten Sie VS Code neu

Lösung 1: Aktualisieren Sie den java.home-Pfad im vs-Code

Öffnen Sie einfach die Arbeitsbereichseinstellungen in Visual Studio Code. Und ändern Sie diese Zeile von.

"java.home": "/Library/Java/JavaVirtualMachines/adoptopenjdk-8.jdk/Contents/Home"

Zu

"java.home": "/Library/Java/JavaVirtualMachines/adoptopenjdk-11.jdk/Contents/Home"

Lösung 2: Java 11 erforderlich, um Spring Boot zu verwenden

Hier zum Einsatz Spring Boot-Tools Benötigt Java 11, um Spring Boot zu verwenden.

  1. Öffnen Sie Visual Studio-Code
  2. CRTL + , um die Einstellungen zu öffnen
  3. Suche spring-boot.ls.java.home
  4. Wählen Sie „In settings.json bearbeiten“ aus.
  5. Ihre Java 11-Installation → „spring-boot.ls.java.home“: „C:Program FilesJavajdk-11.0.10“
  6. Speichern und starten Sie VS Code neu

Lösung 3: JDK 11 herunterladen und installieren

  • Laden Sie JDK 11 herunter und installieren Sie es.
  • Sobald die Installation abgeschlossen ist, in C:Program FilesJava Sie werden so etwas sehen
  • Öffnen Sie dann VSC und gehen Sie zu Einstellungen (STRG + oder Symbol Verwalten (unten links) > Einstellungen) und suchen Sie nach javahome
  • Klicken Sie jetzt rein Edit in settings.jsonhinzufügen C://Program Files//Java//jdk-11.0.8 zu java.home und speichern Sie die Datei. So etwas sollte man haben
{
    "java.home": "C://Program Files//Java//jdk-11.0.8"
}
  • Starten Sie VS Code neu.
  • Sie werden so etwas sehen: Sicherheitswarnung! Erlauben Sie diesem Arbeitsbereich, die Variable java.home festzulegen? java.home: C://Programme//Java//jdk-11.0.8
  • Klicken Sie auf Zulassen und Sie können loslegen.

Zusammenfassung

Es dreht sich alles um dieses Thema. Ich hoffe, alle Lösungen haben Ihnen sehr geholfen. Kommentieren Sie unten Ihre Gedanken und Ihre Fragen. Kommentieren Sie auch unten, welche Lösung für Sie funktioniert hat?